[fonosfera] opkg installs modules for wrong kernel version on FON2303_2.3.7.0_beta1_DEV

Matthijs Kooijman matthijs at stdin.nl
Thu Aug 25 20:36:07 UTC 2011


Hi Frank,

> Kernel version for ipv6 module is different to running kernel so it
> can not be installed.
Yup, that's a know limitation of using the OpenWRT opkg repositories.
Most software works, but their kernel is different, so kernel modules
will never work like this.

Upgrading the kernel won't work, since the Ralink wifi and USB drivers
only work with this particular kernel version.

If you need a custom module, you'll have to compile your own firmware
version and enable the kernel module. See
http://trac.fonosfera.org/fon-ng/wiki/build

Alternatively, the firmware compiled by Paolo Valleri might be of
interest to you: http://disi.unitn.it/~valleri/fon/#firmware

Gr.

Matthijs
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://fonosfera.org/pipermail/development/attachments/20110825/cbd91084/attachment.pgp>


More information about the Development mailing list